php 보안강화 issue

PHP강좌 2015.04.02 09:34 Posted by 재현아빠 Jason Hong

3. php 버전업데이트를 하였는데 변수 값이 정상적으로 넘어가지 않습니다.



register_globals = On

register_globals 옵션 설정을 On으로 설정하여 보시기 바랍니다.

GET, POST, COOKIE, SESSION 의 구분없이 변수명을 곧바로 이용할 수 있습니다.

php 의 상위버전부터는 보안상의 이유로 GET, POST, COOKIE, SESSION 등

변수명을 바로 이용하지 못하도록 php.ini 에 register_globals옵션이 off으로 설정되어있습니다.




구글검색 검색어 :php 환경설정 register_globals

참고사이트

http://kstyle.tistory.com/attachment/ik50.pdf

신고

'PHP강좌' 카테고리의 다른 글

php 보안강화 issue  (0) 2015.04.02
변수와 상수에 대하여  (0) 2015.03.22
PHP시작하기  (0) 2015.03.22


 

티스토리 툴바